stuebinm
0e1f14957e
in summary:
- update inputs
- copy a fix for the nopersist module from hexchen's nixfiles
d0b3a042ff
- remove an already-outdated override in pkgs
- update zola's config for the docs.hacc.space website
34 lines
752 B
Nix
34 lines
752 B
Nix
{ sources, ... }@args:
|
|
|
|
let
|
|
pkgs = import sources.nixpkgs args;
|
|
oldstable = import sources.nixpkgs-oldstable args;
|
|
unstable = import sources.nixpkgs-unstable args;
|
|
|
|
callPackage = pkgs.lib.callPackageWith (pkgs // newpkgs);
|
|
|
|
newpkgs = {
|
|
|
|
mattermost = callPackage ./mattermost.nix {
|
|
buildGoModule = unstable.buildGo122Module;
|
|
};
|
|
|
|
morph = callPackage ./morph.nix {
|
|
buildGoModule = unstable.buildGo122Module;
|
|
};
|
|
|
|
forgejo = unstable.forgejo;
|
|
|
|
tracktrain = import sources.tracktrain {
|
|
nixpkgs = unstable;
|
|
compiler = "default";
|
|
};
|
|
|
|
uffd = oldstable.callPackage ./uffd { };
|
|
|
|
hacc-scripts = callPackage ./scripts {};
|
|
|
|
inherit (oldstable) uwsgi flask;
|
|
};
|
|
|
|
in pkgs.extend(_: _: newpkgs)
|