forked from hacc/haccfiles
Lukas Schulz
e790e89057
closes !3 commit c7fead272d8777568a1a2bc9d5c9eb60edc7079b Author: Lukas Schulz <lukas.schulz@simiworld.de> Date: Sun Nov 29 15:30:47 2020 +0100 removed false }; commit a6ea75a6d295846aeef96053caf28281d88af6b0 Author: Lukas Schulz <lukas.schulz@simiworld.de> Date: Sun Nov 29 15:28:57 2020 +0100 moved stuff to common.nix commit 8e2815884ae6e550547594a71a206dd023fe042d Author: Lukas Schulz <lukas.schulz@simiworld.de> Date: Sun Nov 29 15:17:25 2020 +0100 added nginx statuspage for netdata to find Signed-off-by: hexchen <hexchen@lilwit.ch>
61 lines
1.5 KiB
Nix
61 lines
1.5 KiB
Nix
{config, lib, pkgs, ...}:
|
|
|
|
{
|
|
networking.firewall.allowedTCPPorts = [
|
|
80 # HTTP
|
|
443 # HTTPs
|
|
];
|
|
|
|
services.netdata = {
|
|
enable = true;
|
|
configText = ''
|
|
[global]
|
|
dbengine multihost disk space = 2307
|
|
'';
|
|
};
|
|
|
|
# Enable nginx service
|
|
services.nginx = {
|
|
enable = true;
|
|
# Use recommended settings
|
|
# Don't use recommended Proxy settings because it does funky things with the setup
|
|
recommendedGzipSettings = true;
|
|
recommendedOptimisation = true;
|
|
recommendedTlsSettings = true;
|
|
virtualHosts."${config.networking.hostName}.live.hacc.media" = {
|
|
forceSSL = true;
|
|
enableACME = true;
|
|
# basicAuth = basicAuthLogin;
|
|
locations = {
|
|
"/stats" = {
|
|
return = "301 /stats/";
|
|
};
|
|
"~ /stats/(?<ndpath>.*)" = {
|
|
proxyPass = "http://127.0.0.1:19999/$ndpath$is_args$args";
|
|
extraConfig = ''
|
|
proxy_redirect off;
|
|
proxy_set_header Host $host;
|
|
|
|
proxy_set_header X-Forwarded-Host $host;
|
|
proxy_set_header X-Forwarded-Server $host;
|
|
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
|
|
proxy_http_version 1.1;
|
|
proxy_pass_request_headers on;
|
|
proxy_set_header Connection "keep-alive";
|
|
proxy_store off;
|
|
|
|
gzip on;
|
|
gzip_proxied any;
|
|
gzip_types *;
|
|
'';
|
|
};
|
|
"/nginx_status" = {
|
|
extraConfig = ''
|
|
stub_status;
|
|
auth_basic off;
|
|
'';
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|