haccfiles/pkgs/matrix/default.nix
stuebinm 2afc9befbf
matrix-synapse: bump to nixos 21.05, new structure
This patches an import path for our new structure, and adjusts the build
inputs for our hacked version of matrix-synapse with a newer version of
twisted (for tls 1.3 support), which is apparently still necessary even
in nixos 21.05.

Seems to build fine (have not waited for all tests in the matrix packag;
these take ages)
2021-08-26 22:55:47 +02:00

53 lines
1 KiB
Nix

self: super:
{
python38Packages = super.python3Packages // {
twisted = with super.python3Packages;
twisted.overrideAttrs (old: rec {
version = "21.2.0";
src = fetchPypi {
inherit version;
extension = "tar.gz";
pname = "Twisted";
sha256 = "04jsr67swzj8vn8z64fzbha7vpkm1jz9ns26566vjsfg8n4llm3p";
};
});
};
matrix-synapse = super.matrix-synapse.overrideAttrs (old: {
propagatedBuildInputs = with self.python3Packages; [
authlib
bcrypt
bleach
canonicaljson
daemonize
frozendict
ijson
jinja2
jsonschema
lxml
msgpack
netaddr
phonenumbers
pillow
prometheus_client
psutil
psycopg2
pyasn1
pyjwt
pymacaroons
pynacl
pyopenssl
pysaml2
pyyaml
requests
setuptools
signedjson
sortedcontainers
treq
twisted
typing-extensions
unpaddedbase64
];
python = self.python3;
});
}