forked from hacc/haccfiles
stuebinm
c2c0bd366a
This simply updates nixpkgs to 21.11 (along with a general update of other sources), then follows the hints given out in the build process until everything (on parsons) ran through fine. Some things to note: - syncthing's declarative config is gone. Instead, declarative and non-declarative configuration can now be mixed, but with `overrideDevices` set to true, it _should_ ignore non-declarative settings and basically behave the same as before (or at least that's how I understood the documentation on that) - some postfix options now require a lib.mkForce, since the mail module also wants to set them — we should probably look into if the mail module has nicer ways of handling our settings now (which I didn't do) - we no longer import the vaultwarden module from unstable, since it's included in nixos 21.11 as-is. We _do_ still import the vaultwarden package from unstable, since downgrading sounds like a bad idea. - nix build will print a warning that `literalExample` is now depricated, but we don't seem to use that — I guess at some point we'll have to search through our sources if it doesn't go away This was not yet deployed, and should probably considered a work-in-progress. Building Nixda currently fails decklink seems to have disappeared.
64 lines
2.3 KiB
Nix
64 lines
2.3 KiB
Nix
{config, pkgs, lib, ...}:
|
|
|
|
{
|
|
services.gitlab-runner = {
|
|
enable = true;
|
|
concurrent = 4;
|
|
services = {
|
|
infra4future = {
|
|
buildsDir = "/persist/var/lib/gitlab-runner/builds";
|
|
dockerImage = "nixos/nix";
|
|
executor = "docker";
|
|
registrationConfigFile = "/persist/var/lib/gitlab-runner/gitlab-runner.env";
|
|
};
|
|
nix = {
|
|
limit = 1; # don't run multiple jobs
|
|
registrationConfigFile = "/persist/var/lib/gitlab-runner/gitlab-runner.env";
|
|
dockerImage = "alpine";
|
|
dockerVolumes = [
|
|
"/nix/store:/nix/store:ro"
|
|
"/nix/var/nix/db:/nix/var/nix/db:ro"
|
|
"/nix/var/nix/daemon-socket:/nix/var/nix/daemon-socket:ro"
|
|
];
|
|
dockerDisableCache = true;
|
|
preBuildScript = pkgs.writeScript "setup-container" ''
|
|
mkdir -p -m 0755 /nix/var/log/nix/drvs
|
|
mkdir -p -m 0755 /nix/var/nix/gcroots
|
|
mkdir -p -m 0755 /nix/var/nix/profiles
|
|
mkdir -p -m 0755 /nix/var/nix/temproots
|
|
mkdir -p -m 0755 /nix/var/nix/userpool
|
|
mkdir -p -m 1777 /nix/var/nix/gcroots/per-user
|
|
mkdir -p -m 1777 /nix/var/nix/profiles/per-user
|
|
mkdir -p -m 0755 /nix/var/nix/profiles/per-user/root
|
|
mkdir -p -m 0700 "$HOME/.nix-defexpr"
|
|
. ${pkgs.nix}/etc/profile.d/nix.sh
|
|
${pkgs.nix}/bin/nix-env -i ${lib.concatStringsSep " " (with pkgs; [ nix cacert git openssh ])}
|
|
${pkgs.nix}/bin/nix-channel --add https://nixos.org/channels/nixpkgs-unstable
|
|
${pkgs.nix}/bin/nix-channel --update nixpkgs
|
|
'';
|
|
environmentVariables = {
|
|
ENV = "/etc/profile";
|
|
USER = "root";
|
|
NIX_REMOTE = "daemon";
|
|
PATH = "/nix/var/nix/profiles/default/bin:/nix/var/nix/profiles/default/sbin:/bin:/sbin:/usr/bin:/usr/sbin";
|
|
NIX_SSL_CERT_FILE = "/nix/var/nix/profiles/default/etc/ssl/certs/ca-bundle.crt";
|
|
};
|
|
tagList = [ "nix" ];
|
|
};
|
|
};
|
|
};
|
|
|
|
systemd.services.gitlab-runner.serviceConfig = {
|
|
DynamicUser = lib.mkForce false;
|
|
User = "gitlab-runner";
|
|
};
|
|
|
|
users.users.gitlab-runner = {
|
|
home = "/persist/var/lib/gitlab-runner";
|
|
extraGroups = [ "docker" ];
|
|
isSystemUser = true;
|
|
group = "nogroup";
|
|
};
|
|
|
|
virtualisation.docker.storageDriver = "zfs";
|
|
}
|